Jump to content
Sign in to follow this  
FridayThe31st

Can’t Find US Servers?

Recommended Posts

For the past few days, on Xbox,  my game was acting kind of weird. When starting it up it would take forever to search for dedicated servers. When it finally got one, it was never a US one. One time it was SA - with people speaking an entirely different language - and almost all the time it was Europe. Most of the people talking sounded like they were from Europe, but last night I came across some people (who ended up being damn teamers) who were all confused as to why they were put into a Europe server. I was also because that was the first time that ever happened to me (well if they wouldn’t have said anything I guess I wouldn’t have noticed, but still, it was the first time I could recall). My ping was also pretty high the times I was put in European servers as I’m from the US. I was just wondering if anybody here who plays on Xbox has also recently experienced this. I know it’s not really a bad thing (except for when I can’t understand a word one people are saying when they are talking that is, and when my ping is really high which doesn’t usually happen), but I was just wondering if anybody else was experiencing this or if it’s just me. 

Share this post


Link to post
Share on other sites

Yeah I play Xbox too and the last couple of days it's either SA or EU Servers and also horrible load times just trying to get into a game.

 

Then today and a couple of other people got kicked from a server in the middle of a game at least twice.

I'm in Buffalo, NY so yeah it's a thing :\

Share this post


Link to post
Share on other sites
7 hours ago, Global_Meltdown said:

Yeah I play Xbox too and the last couple of days it's either SA or EU Servers and also horrible load times just trying to get into a game.

 

Then today and a couple of other people got kicked from a server in the middle of a game at least twice.

I'm in Buffalo, NY so yeah it's a thing 😕

I’m in NJ, I thought it was only me. I wonder why that’s happening.

Share this post


Link to post
Share on other sites
15 minutes ago, The Rain said:

It must be for the new number of new players. Collapse

It amazes me there are still new players joining. Hopefully they realize it's a cash cow and come up with a part 2 after all the lawyer schmawyer stuff is done.

Share this post


Link to post
Share on other sites
Just now, MRWood204 said:

It amazes me there are still new players joining. Hopefully they realize it's a cash cow and come up with a part 2 after all the lawyer schmawyer stuff is done.

 

the game is free until November 15 for that the new large number of players.

I hope there is a part 2

Share this post


Link to post
Share on other sites

🙋‍♀️ Same here, was playing on the EU server never got on the US server.... well since last night, haven’t tried today.

Share this post


Link to post
Share on other sites

Same but I'm on PS4. I've been getting 95% CA servers and I live in Kansas. This has been happening to me since the last patch. Doesn't seem to matter what time of day. However, if I join a party with one or more then it's almost always a US server we can get into.

This does NOT happen to me with Steam though. 99% I get US servers every single time.

Share this post


Link to post
Share on other sites

This could definitely be due to an influx of players for the free period on Xbox. Have things settled down as far as connections go or is this still happening?

Share this post


Link to post
Share on other sites
5 hours ago, mattshotcha said:

This could definitely be due to an influx of players for the free period on Xbox. Have things settled down as far as connections go or is this still happening?

I was put into AP servers as well, forgot to add that. But I do agree, I think it’s because of the number of new players. Lately though I’ve had little to no connection problems, I’ve been put in US servers as usual.

Share this post


Link to post
Share on other sites

 hey this   thing happenin still  if it does try this stop using dns 1.1.1.1 and 1.0.0.1  thats what i did    am now using other dns  cuz of this wierd problem supposedly 1.1.1.1 are suppose to be the fastest

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...